パスワードを忘れた? アカウント作成
この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。

ほとんどのAndroid端末では「最新OS」を利用できない」記事へのコメント

  • 何世代も前(今時なら1.xとか)だと、
    さすがにアプリもサポートしてくれないだろうし、
    実用上問題が出てきそうだけど、
    1、2世代前程度でも、それ程問題になるものなの?

    Androidの事情は詳しくはわからん、教えてエロい人。
    • Re: (スコア:3, 参考になる)

      by Anonymous Coward

      Android の場合、
      2.1 → 2.2 Java 速度の向上
      2.2 → 2.3 NDK(ネイティブコード)による実装を大幅強化
      2.3 → 4.0 (3.x は無視で) で NFC や USBホスト機能等を搭載
      って感じで機能は上げっている。
      2.1 から 2.2 は大幅に速度が違っているし上げておいた方が良いけど、それ以上のものは特に必要ないかな。
      iOS みたいに新しいサービスとかが追加になるわけではないし、ハードベンダー側がOSに合わせて組み込まないといけないので障害も大きい。

      SDK レベルでは 2.1 以上の想定でほとんど問題なく動くからアプリ開発者はその辺をターゲットで十分。

      • by Anonymous Coward on 2011年10月28日 23時18分 (#2041694)

        パフォーマンス的には、
        2.2 → 2.3 Concurrent GCの採用
        これがかなり大きい。
        最大速度は変わらないけど、ボトルネックとなる部分が劇的に改善した。
        スクロールしてひっかかることとかが2.3でほとんどなくなった。

        親コメント

※ただしPHPを除く -- あるAdmin

処理中...