パスワードを忘れた? アカウント作成
この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。

電子政府が使えない理由、縦割りの弊害?JREの弊害?」記事へのコメント

  • ってそんな駄目駄目なの?
    • by Anonymous Coward
       Java使いじゃないものの素人考えとしては、バージョン依存しないような書き方をすればすむものじゃないの?
      • Re:JREの互換性 (スコア:0, 参考になる)

        by Anonymous Coward
        >>バージョン依存しないような書き方をすればすむものじゃないの?
        ないからこういう問題になっている。
        というか出来ないといったほうが正解。
        Javaのプラットフォーム間の互換性は同一バージョン下でのお話。それとて結構怪しいもんですが。

        • Re:JREの互換性 (スコア:1, すばらしい洞察)

          by Anonymous Coward
          >> バージョン依存しないような書き方をすればすむものじゃないの?
          > ないからこういう問題になっている。

          これ、具体的にお願いします。

          こういう場合って、たいてい筋の悪いプログラムを書いているせいだと思うのだけど、そうでない例があれば教えてください。
          • by Anonymous Coward
            クラスライブラリがの仕様がバージョンによって
            ガラリと変わるんだから、ダメダメ。

            メソッドがごっそりなくなってたりするから、
            プログラマの技量どうのこうので解決する問題じゃないでしょ。

            変えた理由が、このクラスの実装は美しくないから、
            もっとすっきりした構造にしました、とかだし。
            「これとこれ、無くなったから。代わりにこれを使ってね。こっちのほうがきれいでしょ」とか。

            こんな学生が卒業研究で試行錯誤しながらコンパイラ作ってるようなレベルの議論と理由で
            仕様がどんどん変わっていく様は、見ていてあいた口がふさがらなくなる。

身近な人の偉大さは半減する -- あるアレゲ人

処理中...