パスワードを忘れた? アカウント作成
この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。

電子政府が使えない理由、縦割りの弊害?JREの弊害?」記事へのコメント

  • ってそんな駄目駄目なの?
    • by Anonymous Coward
       Java使いじゃないものの素人考えとしては、バージョン依存しないような書き方をすればすむものじゃないの?
      • by ducky (16839) on 2006年03月26日 20時57分 (#909289)
        例えば、Windowsなんたらだけ動作対象となっている場合、開発会社が調達してきた独自の
        ライブラリを使っている可能性はあります。

        独自のライブラリの中には、特定のバージョンでのJRE環境でのみ動作を保証している
        ものもあります。

        今回の件とは違う例だけど、Excelを直接起動するような作りにするときに、Excel.exeの
        絶対パスを、文字列で埋め込むことを強制されたので、Officeのバージョンが変わると
        動かなかったり。

        互換性は、JREだけがすべての原因ではなく、いろいろなところに関わってくる問題なのが
        現実なので、Javaだけに目をとらわれていると、単にSunを叩くだけの話になっちゃう。
        親コメント

海軍に入るくらいなら海賊になった方がいい -- Steven Paul Jobs

処理中...