パスワードを忘れた? アカウント作成
11755 story

Firefox1.5.0.1リリース 55

ストーリー by yoosee
あの狐の動きが軽快にっ 部門より

いきなり更新通知が現れてびびったElbereth曰く、"Firefox 1.5.0.1がリリースされました。 リリースノート(英文)によると、概要、変更内容は以下の通り(拙訳)。

2006年2月1日 Firefox1.5.0.1は、私達の顧客へ安全なインターネット体験を提供するために進行しているプログラムの一部であり、安定性とセキュリティのためのアップデートです。私達は全てのユーザーがこの最新版にアップデートすることを推奨します。

Firefox 1.5.0.1 の更新点
  • 安定性を改良
  • Mac OS Xのサポートを改良
  • アイスランド(.is)の国際ドメインネームサポートが可能になった
  • いくつかのメモリリークの修正
  • いくつかのセキュリティ増強
バグフィックスの詳細については、Unofficial Firefox 1.5.0.1 changelogを参照のこと。
タレコミ本人の自動アップデートは残念ながら(サーバー側が激重なためか)失敗してしまったが、日本語版のフルインストール用バイナリがダウンロードできるようになっています。
ちなみに、Mozilla Japanでは、タレコミ時点ではまだ素のFirefox1.5を配布しているものの、近いうちに更新されるのではないかと思われます。"

この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。
  • 今回はいい感じ (スコア:5, 参考になる)

    by kawaz (15398) on 2006年02月02日 16時50分 (#875744) ホームページ
    僕も自動更新チェックが気が付いたクチです。
    いつもなんの役に立つんだこれ?ってくらい更新が遅いのにそれが改善されたとしたら良いことです。

    ちなみについ勢いで人柱よろしくプロファイルフォルダをバックアップせずにいきなりアップデートしてしまったんです、が動かなくなった拡張とかはありませんでした(^^;;;

    ちなみに入れてた拡張は以下の通りです。
    DOM Inspector
    Launchy
    Forecastfox
    Google Toolbar for Firefox
    PDF Download
    Html Validator
    ShowIP
    Flat Bookmark Editing
    Text Link
    IE Tab
    All-in-One Gestures
    User Agent Switcher
    Tab Mix Plus
    Live HTTP Headers
    Venkman JavaScript Debugger
    Web Developper
    Open As Webfolder
  • by moromama (23126) on 2006年02月02日 16時46分 (#875742) 日記
    できましたよ。今朝。
    それだけですが。
    --
    Minder
    • by kicchy (4711) on 2006年02月02日 16時50分 (#875745)
      報告だけになってしまいますが
      ウチでは、差分更新に失敗した、というメッセージがでて
      全体取りに行きます、とかいう流れになって
      結局更新は成功したみたいです。

      # windows XPにて
      親コメント
      • 同じく、差分更新には失敗して全体の更新に成功しました。
        何が原因なんでしょうか…。
        自分の場合、browser.jarのコードを一部書き換えて
        使っているので、その辺りかなと思ったのですが。
    • by Elbereth (17793) on 2006年02月02日 18時04分 (#875793)
      タレコミした本人ですが、自動更新に失敗してから
      タレコミを書くなどした後、Firefoxを終了したら
      自動アップデートのダイアログが出て、そこでは
      すんなりと更新が完了しました。

      当初はサーバー側が重くて通信に失敗したのかと思っていたのですが
      上記のようなわけで、失敗と出たのは別の原因と思われます。

      他に失敗した原因としてありそうなのは、更新時に2つ
      ウィンドウを開いていたことくらいかなとは思いますが
      詳しく検証したわけでもないので、テキトーな話です。
      親コメント
    • by moromama (23126) on 2006年02月02日 20時17分 (#875858) 日記
      追加、さっきのはwinxpだったが、OSXも自動アップデートok。
      2chreaderもアップデートで、OSX10.4.4で使えるようになった・・・
      --
      Minder
      親コメント
    • 自分も。
      windows2000で差分アップデートに必ず失敗。
      フルダウンロードで更新した。

      # それだけなのでAC
    • NortonInternetSecurity2005+WindowsXP(SP2)の環境でやってみると自動更新自体は成功しますが、
      その後Nortonが再設定を求めてきます。
      それで再設定して画面の表示が許可になっていても実質的に拒否になっているので、
      ファイアウォールの設定画面で一度消去・その画面から再設定します。するとつながります。

      #微妙にずれた話かもしれませんが。
  • Mozilla Japanも更新 (スコア:2, 参考になる)

    by Elbereth (17793) on 2006年02月02日 18時07分 (#875797)
    Mozilla Japanですが、今見たら1.5.0.1配布するように更新されていますね。
    リリースノートの更新などはまだのようですが。
  • by Anonymous Coward on 2006年02月03日 0時04分 (#876029)
    拡張動いた動かない祭はいい加減何とかならんのかねぇ。
    ユーザーの評価も落ちるし拡張作者の負担にもなる。
    こんなわけのわからないルールは他に見たことないよ。
    • by Anonymous Coward on 2006年02月03日 0時14分 (#876037)
      1.5.0.*にしろとさんざん言われてたのに聞いてなかった拡張作者に言ってください。
      本当にメンテナンスリリースの0.0.0.1アップでも動かなくなる拡張だったら仕方ありませんけどそんなの滅多にないし
      親コメント
      • by Anonymous Coward on 2006年02月03日 2時14分 (#876085)
        > 本当にメンテナンスリリースの0.0.0.1アップでも動かなくなる拡張だったら仕方ありませんけどそんなの滅多にないし

        それならなおさら、ユーザーに余計な負担をかけてまで、maxVersion に 1.5 を指定している拡張を無効化する必要はないですね。

        私は拡張を利用するだけの立場ですが、対応バージョンを指定するときに 1.5 ではなく、わざわざ 1.5.0.* と指定しなくてはならないのには何か理由があるのでしょうか?

        素人考えかもしれませんが、1.5 と指定してあったら、1.5.*.* と解釈するのが妥当だと思うのですが。
        親コメント
        • by Motohiko (15295) on 2006年02月03日 7時47分 (#876124) ホームページ

          素人考えかもしれませんが、1.5 と指定してあったら、1.5.*.* と解釈するのが妥当だと思うのですが。

          いい線だとは思います。

          1.5と完全に互換性を有する (ということにされている) ものが、今回の1.5.0.x系列です。で、万が一互換性を維持しきれない (APIの変更を必要とする) 修正が必要だった場合に備えて、1.5.x.x系列が用意されています。この2種類の修正版の系列を用意したのは、Firefox 1.0.5でAPIの変更が行われ問題が多数発生した為1.0.6を要した経験 [slashdot.jp]に基づいています。

          明言はされていませんが、例えば 1.5→1.5.0.1→1.5.0.2→(API変更)→1.5.1→1.5.1.1 みたいな感じでリリースされるのではないかと思っています。…判り辛いですね。判り辛いが故に何度か告知されている (Mozilla Developer News » Blog Archive » Extension Versioning in Firefox and Thunderbird 1.5 [mozilla.org], Mozilla Developer News » Blog Archive » Firefox Extension Versioning [mozilla.org]) んですが。

          とはいえもっとスマートな方法は無かったのか、とは最初にバージョン付けルールが公開された時に私も思いましたけど。

          親コメント
          • >とはいえもっとスマートな方法
            普通許容されるのは1.*.*.*という指定だけだと思うけど。
            バグ・セキュリティの修正なら原則挙動は変わらないし
            インターフェース・機能の修正ならAPIを「追加」すべき。
            # Fooに対してFooEx, FooExEx, ...

            Firefoxは拡張の資産が非常に重要なんで
            1.5.1, 1.6(2.0ですら)が出たらまた拡張全滅という事態は避けないとまずいでしょ。
            毎回ユーザーや拡張作者を振り回しても数の力で新陳代謝していけば
            何とかなると踏んでいるならそれはひとつの考え方かもしれないけど、
            果たして日本はついていけるのか…
            • 確かにAPIを度々変更するのはよくないな。FirefoxだけじゃなくてRubyなんかも1.6から1.8やあるいは、同じ1.8.xの間でも問題が生じている。

              WindowsのAPIなんかはその増設をやりすぎて、下手なやり方でやって凄いことになってしまってはいるので、この中間位のバランスでやってほしい。

              例えば、1.x.x の間はAPIを変えない。もしAPIを変えるなら2.x.xまで我慢するとか。
        • それだと、1.5.0 で動いて、1.5.0.1 で動かないような拡張だった場合に不具合出るような気が。
          その対策に「厳密に1.5」という指定の仕方を加えると、今以上に面倒臭くなるだけだと思います。
          • > それだと、1.5.0 で動いて、1.5.0.1 で動かないような拡張だった場合に不具合出るような気が。

            その場合は 1.5.0.0 と指定すればいいだけではないのですか?
            • 1.5.0.0.1が出たらどうするんですか?
              • by Anonymous Coward
                自作の拡張の寿命をあらかじめ設定しておかなければならないこと。
                将来どのバージョンで動かなくなるかなんて分かるわけがない。
              • 自作の拡張の寿命をあらかじめ設定しておかなければならないこと。
                将来どのバージョンで動かなくなるかなんて分かるわけがない。

                いえ、「寿命」ではなく、現行の最新バージョンを指定すべしというのが、最高バージョン番号設定の基本的なルールになっています。 最新リリース版の番号より新たなものを設定してはならない、という記述がExtension Versioning [mozilla.org]のChoosing minVersion and maxVersion節にあります (既にこの原則は崩れているようですが)。

                で、新バージョンがリリースされたら (リリース候補の時点で?)、製作者が互換性を確認し、更新マニフェストファイルを書き換えます。本体の更新時、或いは拡張マネージャで対応版の存在の確認をすると、更新マニフェストファイルを解析して、最高バージョン番号を書き換えます。

                つまり、予め寿命を指定するのではなく、(アプリケーション) 本体のバージョンアップ毎にリモートのデータソースを書き換えろ、というのがFirefoxの拡張マネージャの設計です。更新時にプラグインパッケージの読み込みが不要になっていることに注意して下さい (Bug 251473 [mozilla.org])。ちなみにデータソースの量は1kB/拡張・テーマ、程度です。

                親コメント
        • 素人考えですね
  • メモリ・リーク (スコア:1, 参考になる)

    by Anonymous Coward on 2006年02月03日 4時07分 (#876096)
    W2kで使ってみて、タスクマネージャのメモリ使用量を確認してみたところ、
    30MB~40MBぐらいでした。
    前バージョンが使っていると、どんどんメモリ使用量が増えて150MBとかになって
    一旦firefoxを終了させることしてたので、やっと使える感じです。
    • by Anonymous Coward on 2006年02月03日 9時18分 (#876152)
      使用量が増えたのはタブを沢山開いたからではないでしょうか。
      それとメモリはリークじゃなくて解放しない方の問題では?
      http://andore.com/inami/mtarchives/003249.html [andore.com]
      親コメント
    • by blacat (29477) on 2006年02月03日 13時58分 (#876384)
      自分もw2kですが、今バージョンでも240MBとか使ってますよ。
      そもそも修正箇所 [mozilla-japan.org]の中に該当するものがあるんですか?

      ああ、まだ増え続けてる…
      --
      リソース不足注意報!!
      親コメント
      • by Anonymous Coward
        >自分もw2kですが、今バージョンでも240MBとか使ってますよ。
        >そもそも修正箇所の中に該当するものがあるんですか?
        そのリンク先のタイトルには「Mozilla 製品における既知の脆弱性」と明記してあって、元の話題はメモリリーク。たれ込み文には「バグフィックスの詳細については、Unofficial Firefox 1.5.0.1 changelogを参照のこと。 」
        とある、さて問題です、なんで「(スコア:1) 」なんでしょう?
  • by Anonymous Coward on 2006年02月02日 18時10分 (#875800)
    名前解決しなくなちゃいました。
    IPアドレスではアクセスできるんだけど

    うーん みんなうまくいってんだぁ....
  • by Anonymous Coward on 2006年02月02日 18時17分 (#875807)
    いつもはフル版インストールで気づいていなかったのですが、初回起動時だけスタートページがGoogleベースではなく、Yahooベースになってました??
    前からですか?
    • by Anonymous Coward
      今Updateしたら、ここ [mozilla-japan.org]に飛ばされました。

      GoogleベースからYahooベースになったのは1.5のときだったと思います。
typodupeerror

アレゲは一日にしてならず -- アレゲ研究家

読み込み中...