パスワードを忘れた? アカウント作成

こちらは、Henrichさんのユーザページですよ。 アカウントを作成して、スラドのモデレーションと日記の輪に参加しよう。

13395167 comment

Henrichのコメント: アップグレードにはaptitudeは非推奨です(Re:悪いことは言わん (スコア 2) 17

by Henrich (#3270701) ネタ元: Raspbian Strechリリース

まっさらなところからやったほうがアップグレードに伴うトラブルは避けられるよ、という点は同意しますが

>Stretchからはsystemdの仕様が強制適応されるので

Jessieからsystemd使ってるので、Stretchになったからという理由は説得力に欠けます。
具体的にどの「仕様」なのでしょう。

> 後はお約束だからって
> 依存地獄の解消に何の役にも立たないapt-getを
> 周知し続けるのも問題かなぁ
>
> 手痛い洗礼を有難がれで裾野が広がる時代じゃないんだし
> せめてaptitudeにしようよみたいな

明らかに間違いです。アップグレードにはapt-getが推奨されます(アップグレード時のaptitudeの利用は非推奨で、aptitudeをアップグレードに使うと依存関係の解決時にループ状態に陥ることがあります)。

アップグレードにaptitudeではなくapt-getを使うのが推奨されるのはDebian6.0 "Squeeze"の頃からリリースノートに明記されています。2011年のことです。
aptitudeが推奨されていたのはDebian3.1からDebian 5.0の頃の古い古い話です。

13254829 comment

Henrichのコメント: Re:tab mix plus (スコア 1) 43

「バージョン変えずにセキュリティパッチ当てる」のはRHEL(CentOS)とかSUSEとかでも普通に見られることなので、なんでDebianが名指しででてくるのかよくわかりません。

DebianではFirefoxはESRでいくのは規定事項だし、開発リソースをそんな後ろ向きなことに使う余裕はないでしょうね。firefoxパッケージメンテナのMikeさんもMozillaのお仕事で忙しいでしょうし。
13253379 comment

Henrichのコメント: Re:無効化した鍵はSSH鍵じゃなくてGPG鍵の方です (スコア 1) 40

というか、記事自体がもっとちゃんと書いたほうが良いですよね、これ。

他にも、タイトルでDebian開発者って書いてるけど「Debian developer」はDebianプロジェクトで認定のプロセスを経た公式の開発者(平たく言うと @debian.org なアドレス持ってる人)で、Dmitryさんは「Debian maintainer」(幾つかのパッケージについてだけアップロード権限を与えられてる人)なので違うんですよね。

13253342 comment

Henrichのコメント: 無効化した鍵はSSH鍵じゃなくてGPG鍵の方です (スコア 1) 40

コメントを見てると誤解されてる人が多いようなので...

パッケージをリポジトリにアップロードする際にデジタル署名するんですよ。
で、キーリングにあるGPG鍵による署名だったらパッケージをリポジトリに登録する処理をします(説明を大幅に端折ってますが)。
キーリング情報は https://anonscm.debian.org/git/keyring/keyring.git 参照。

今回は「ロシア当局が押収したGPG鍵を使って悪意のあるパッケージをリポジトリに登録する可能性があるので、それを防ぐ処置をした」ってことです。
12884985 comment

Henrichのコメント: ツールによる類似率の判定 (スコア 1) 9

今回は間に合わなかったけど、コードのクローンしてるかどうかをツールを使って判定してみたそうな。
https://sfconservancy.org/copyleft-compliance/vmware-code-similarity.html

#ちなみにこのツール、作者は日本の方らしい http://www.ccfinder.net/ccfinderxos-j.html

12639840 comment

Henrichのコメント: Debianパッケージに特化したツールじゃないんだけど。。。? (スコア 1) 40

https://github.com/dod38fr/config-model/blob/master/README.pod を見てもらうとわかるけど、一応「interactive configuration editor」を目指した設定ファイル編集のための汎用ツールなの。

で、それにDebianパッケージ用のプラグインが追加されたよ、という話。

#debパッケージの作成はそんなに難しいとは感じない。通常のプログラム書くほうがよっぽど大変ですよ…。

typodupeerror

UNIXはシンプルである。必要なのはそのシンプルさを理解する素質だけである -- Dennis Ritchie

読み込み中...