パスワードを忘れた? アカウント作成
74893 journal

Livingdeadの日記: ReadyNAS NV+ の Python 2.4 で Trac

日記 by Livingdead

ReadyNAS NV+ のリポジトリでは python2.4 パッケージが提供されている。python2.4 と python2.4-dev をインストールする。今なら 2.6、少なくとも 2.5.2 を使うべきなのだが、面倒なので python 2.4 ベースで Trac を使ってみる。python2.4-setuptoolsパッケージも提供されているが、それはインストールせずに setuptools を直接インストールする。

sh setuptools-0.6c9-py2.4.egg

これで easy_install-2.4 コマンドが使えるようになる。後から Python 2.6.1 をインストールして 2.4 と共存させるつもりなので、Python のバージョンについては徹底的に区別する。easy_install が使えるようにさえなればあとはかなり楽。

easy_install-2.4 Trac

でGenshi-0.5.1もろともTrac-0.11.4rc1-py2.4.eggがインストールされる。これで trac-admin と tracd が使えるようになっている。Python万歳。先頭行には

#!/usr/bin/python2.4

が指定されており、Pythonのバージョンを区別している。それぞれ trac-admin-2.4 と tracd-2.4 に改名しておいたほうがいいのかな?それは逆にややこしいか?

この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。
typodupeerror

目玉の数さえ十分あれば、どんなバグも深刻ではない -- Eric Raymond

読み込み中...