パスワードを忘れた? アカウント作成
12767962 journal
Windows

airheadの日記: memo: Windowsサウンド不調 2

日記 by airhead

症状:一切の音が出ない。音量コントロールいじった時の確認音も出ない。メディアプレーヤー再生でエラー。これはどれほど関係しているのかわからないが、Webストリーミング再生では、ブラウザとサイトの組み合わせによってエラーが出る。

解決法:ドライバを入れなおす。普通過ぎてちょっと恥ずかしい。同時にメディアプレーヤやブラウザの症状も回復したので、やはりサウンドドライバが原因だったのかもしれないが確証はない。

ただしIEだけは、他が復調後も「ほぼ」復調といったところ。YouTubeを再生できるようになり音も出るが、しばらくすると固まることがある、らじるらじるでは相変わらず再生ウィンドウ開いた時点で固まり、再生までこぎつけない、といった具合。サウンドドライバ以外に原因があるのか不明。また気が向いたときに調べてみようと思う。

以下、未解決時の症状を残しておく。

  • 環境: Foxconn安マザーのオンボードサウンド、Windows10 64bit。
  • ハード関連:スピーカーは生きてる。出力ジャックも問題なさそうだ。シャットダウンして完全に電源断の後、再起動しても治らない。
  • デバイスドライバ関連:
    • デバイスマネージャでは正常。dxdiag.exeでも正常。イベントログに関連してそうなものは見当たらない。
    • サウンドのプロパティ-サウンドタブ最下段のテスト再生でも音は出ない。Windows起動音のような長めの音でも再生アイコンの右向き三角に変化がないので、再生に失敗しているっぽい。
    • サウンドのプロパティ-再生タブ-スピーカーから、スピーカーのプロパティ-詳細タブのテスト再生でも音は出ない。それに加えてこちらでは「[エラー] テスト トーンの再生に失敗しました。」というポップアップが出る。(以下どうやっても音は出ないので、その旨は省略する)
  • メディアプレーヤ関連:
    • WMP12:ライブラリ-音楽からアルバムを開いて再生ボタンを押すと、メディアリスト1曲目のトラック番号の左に、赤丸に白バッテンのアイコンが出る。同アイコンはプレイリストの1曲目の曲名左にも出る。次再生を示す右向き三角は2曲目へ移る。再生ボタンは再生待ち状態で、この間1秒未満。コンテキストメニューでファイルの場所を開くことはできる。
       ボタン連打でアルバム最後までバッテンアイコンがつくと、「ファイルの再生中に Windows Media Player に問題が発生しました。」というポップアップが出る。Webヘルプボタンを押すとページWindows Media Player のエラー C00D11B1に行けるが、役立つ情報はない。ExplorerからメディアファイルをWMPで開くと、即刻同じポップアップが出て再生に失敗する。Webヘルプのページも同じ。
    • Grooveミュージック:アルバムを開いて再生ボタンを押すと、1曲目から次々とトラック番号の左に丸に感嘆符アイコンがついていき、最後まで行くと「再生できません。 / このアプリを引き続き利用するには、最新バージョンをインストールしてください。 / これに関するヘルプを見る / この問題について、Microsoftにフィードバックを送信します。 / 0xc1010003 (0x80040154)」というポップアップが出る。
       一旦そのポップアップが出ると、再度再生を試みても今度はポップアップが出なかったりする。だがいろいろ試してみたところ、リピート再生の指定やトラック数の多いアルバムの再生など、20~30曲連続で再生に失敗するとほぼ確実にポップアップが出るようだ。たまに勝手に閉じてしまうが、クラッシュやフリーズに関するWindowsからの通知はない。
    • 映画&テレビ:再生しようとすると「再生できません。 / このアプリを引き続き利用するには、最新バージョンをインストールしてください。 / 0x80040154 / フィードバックの送信」というポップアップが出る。0x80040154というIDなど、基本的にGrooveミュージックと同じ内容。
  • Webストリーミング:(関係あるのかわからないが、Twitterなどで話題になってないところを見ると、ここだけの問題のように思われる)
    • YouTube:FirefoxやChromeでは音が出ないだけで映像は再生されるが、EdgeやIEでは「エラーが発生しました。しばらくしてからもう一度お試しください。(再生ID:...) 詳細」という砂嵐背景のエラー表示になる。
    • radiko.jp:Chromeでは再生中のようなボタン表示になるが、FirefoxやEdgeではバッファ中を示す再生ボタン点滅のまま。IEではページ表示自体進まず白紙のままで「radiko.jpは応答していません。」とのエラー表示。
    • らじるらじる:Chromeでは再生中のようなボタン表示になるが、FirefoxやEdgeではバッファ中を示す再生ボタン点滅のままで、しばらくすると再生ボタン位置に「コネクション・エラー」と表示される。IEではページ表示は完了するものの再生(ポップアップ)ウィンドウの「同意して聞く」ボタンを押しても無反応。ポップアップウィンドウを閉じると親ウインドウも開き直しになり、「このWebページに問題があるため、Internet Explorerのタブを開き直しました」とのエラー表示。
  • (書きかけ。もう寝る 05/03 00:15 / そういやBIOS見てなかったです。明日見よう。今度こそ寝る 00:30)
この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。
  • はあるんですが... AC-97とHD-Audioの設定がBIOSで間違ってるとかないですか?
    ケースのオーディオジャックへの接続コネクタの形式がAC-97とHDで違うので、そこじゃないか感

    # それがこういう症状になるとも思えませんが...

    --
    M-FalconSky (暑いか寒い)
    • 今日になってドライバ削除→再起動(Windowsにドライバ探させてインストール)を2回ぐらいやったら直りました。ザ・普通ですね。メディアプレーヤやブラウザに出てた症状もIEを除いて元通り。ということはそっちもサウンドドライバが原因だったんでしょうか。オーディオ関係のオーサリングソフトでもない限り、無音になるだけでエラー出すことはないだろうと思い込んでたので、ちょっと意外。

      突然の不調のきっかけが解らず仕舞いなのは残念ですが、YouTubeが砂嵐になったときサウンドドライバを疑うというのは全く発想になかったんで、それを経験しただけでも良しとしましょう。

      親コメント
typodupeerror

犯人はmoriwaka -- Anonymous Coward

読み込み中...