パスワードを忘れた? アカウント作成
147038 journal

cyber205の日記: 玄箱アップグレード(etch -> lenny)[失敗]

日記 by cyber205

Debianのドキュメントを読んでみると、
第4章 以前のリリースからアップグレードする
>4.5.4. まずは apt と aptitude の両方または一方をアップグレード
>いくつかのバグ報告によれば、etch に含まれるバージョンの aptitude パッケージや
>apt パッケージでは、多くの場合、lenny へのアップグレードを行えません。
つまり、パッケージマネージャがlennyのは賢くなってるからそれ先にインストールしろと。
apt-lineにさらにlennyを追加。squeezeを入れるかどうかはまだ決めてない。
随分とapt-lineも増殖してきたものだ。

# Woody
deb http://archive.debian.org/debian/ woody contrib main non-free
deb http://archive.debian.org/debian-non-US woody/non-US main contrib
# sarge
deb http://archive.debian.org/debian/ sarge contrib main non-free
# etch
deb ftp://ftp.dti.ad.jp/pub/Linux/debian etch main contrib non-free
# lenny
deb ftp://ftp.dti.ad.jp/pub/Linux/debian lenny main contrib non-free

apt-get update で追加したパッケージのデータも取得。
KURO-BOX:~# apt-get install aptitude
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
    apt aptitude-doc-ja gcc-4.3-base libc6 libcwidget3 libept0 libgcc1 libncursesw5 libstdc++6 libxapian15 tzdata
Suggested packages:
    dpkg-dev apt-doc bzip2 lzma python-apt debtags locales glibc-doc libcwidget-dev xapian-tools
Recommended packages:
    aptitude-doc-en aptitude-doc libparse-debianchangelog-perl libgpm2
The following packages will be REMOVED:
    apt-utils
The following NEW packages will be installed:
    aptitude-doc-ja gcc-4.3-base libcwidget3 libept0 libxapian15
The following packages will be upgraded:
    apt aptitude libc6 libgcc1 libncursesw5 libstdc++6 tzdata
7 upgraded, 5 newly installed, 1 to remove and 133 not upgraded.
Need to get 13.3MB of archives.
After unpacking 7021kB of additional disk space will be used.
Do you want to continue [Y/n]?
アウアウ…しっかりlibc6アップグレードが要求されてるではないか orz

libc6アップグレード時に再起動が要求されたデーモンは
ssh openbsd-inetd exim4 cron atd の5つで、全て再起動成功。

Preparing to replace apt 0.6.46.4-0.1 (using .../apt_0.7.20.2+lenny1_powerpc.deb) ...
Unpacking replacement apt ...
Setting up apt (0.7.20.2+lenny1) ...
Installing new version of config file /etc/cron.daily/apt ...
gpg: key 6070D3A1: "Debian Archive Automatic Signing Key (4.0/etch) " not changed
gpg: key ADB11277: "Etch Stable Release Key " not changed
gpg: key BBE55AB3: "Debian-Volatile Archive Automatic Signing Key (4.0/etch)" not changed
gpg: key F42584E6: "Lenny Stable Release Key " not changed
gpg: key 55BE302B: "Debian Archive Automatic Signing Key (5.0/lenny) " not changed
gpg: key 6D849617: "Debian-Volatile Archive Automatic Signing Key (5.0/lenny)" not changed
gpg: Total number processed: 6
gpg: unchanged: 6

aptも自動的にアップグレードされ、セットされているgpgキーがリストされた。
こんな感じでlenny版aptitudeのアップグレードはエラーもなく終了。

先のドキュメントの指示に従ってどんどん作業する。

aptitude search "?false"
aptitude safe-upgrade
  :
132 packages upgraded, 25 newly installed, 4 to remove and 0 not upgraded.
Need to get 53.3MB of archives. After unpacking 31.6MB will be used.
Do you want to continue? [Y/n/?]

safe-upgradeなんていう指示が出せるようになってたのね。
oddmakeサメの日記でもちょっと見たような気がしてたけど、はじめて使う機能だわ。
132パッケージもアップグレードして、53MB消費ですか。解凍して32MB? 合計86MBじゃん。
でかいHDD入れてないと怖くてしょうがないな。(NASだからHDD容量は余るほどあるけどね)

恐ろしいのは、これがほぼアーカイブを展開したままの構成だということ。
追加ではsshとlessぐらいしか入れてないもんね。proftpdはとりあえず使わないので削除したし。
いろいろアプリケーションを入れた状態だと、もっと凄いことになっていたに違いない。

Most services that use PAM need to be restarted to use modules built for this new version of libpam.
Please review the following space-separated list of init.d scripts for services to be restarted now,
  and correct it if needed.
Services to restart for PAM library upgrade: exim4 cron atd_

お、PAMのアップグレードもされるのね。
/etc/securetty
もUSBドングルだのMPCなんとかのプラットフォームに対応した
いろいろシリアルポートが増設されているようだ。
ttyも標準のものが63も用意されているのが相変わらず。
幾つかDisableしようかと思ったが、もう面倒なんでそのまんま動かしてみることにした。
/etc/init.d/halt
/etc/init.d/reboot
に関してはいつもの通りAVRにコマンドを送る部分が見つかってハネられた。
テキトーにhaltするところとrebootするところの直前にコマンド入れとけばいいかな。

apt-get safe-update の後、またGPG関連でエラー発生。
W: GPG error: http://archive.debian.org woody Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F1D53D8C4F368D5D
W: GPG error: http://archive.debian.org woody/non-US Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 6FFA8EF91DB114E0
キーは既に取得しているので、もう一度aptへ放り込み直す。
~# gpg --armor --export F1D53D8C4F368D5D | apt-key add -
OK
~# gpg --armor --export 6FFA8EF91DB114E0 | apt-key add -
OK
しかし、apt-get update するとさらにエラーが発生。キーがエクスパイアされています…だって。
W: GPG error: http://archive.debian.org woody Release: The following signatures were invalid: KEYEXPIRED 1138684904
W: GPG error: http://archive.debian.org woody/non-US Release: The following signatures were invalid: KEYEXPIRED 1106852690
W: You may want to run apt-get update to correct these problems
しょうがないので、/etc/apt/sources.list からWoodyの行を削るとエラーは出なくなった。

さて、apt-get upgradeするか。
更新ゼロ…??
じゃ、apt-get dist-upgradeで…
更新ゼロ…?
あれ?

…そして再起動しても立ち上がらない[HDD停止、赤LED6発ループ] orz (続く)

この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。
typodupeerror

Stay hungry, Stay foolish. -- Steven Paul Jobs

読み込み中...