パスワードを忘れた? アカウント作成

2018年、デスクトップLinuxプラットフォームが抱える問題とは?」記事へのコメント

  • by Anonymous Coward on 2018年10月11日 14時53分 (#3495915)

    多数のライブラリーを同梱することでほぼすべてのデスクトップLinuxでの動作を実現…してたっけ?gtk2が使えなくなっていろいろ動かなくなってなかった?

    ここに返信
    • by ncaq (46027) <ncaq@ncaq.net> on 2018年10月11日 16時13分 (#3495970) ホームページ

      gtk+は知りませんけど,
      Firefoxは多数のライブラリを同梱していますよ.
      GentooでもデフォルトではシステムにあるライブラリではなくFirefoxの同梱ライブラリを使うようになっています.
      USEフラグに以下のようなものがあり,これらを有効にしないとシステムのライブラリは使われません.
        - - system-harfbuzz : Use the system-wide media-libs/harfbuzz and media-gfx/graphite2 instead of bundled.
        - - system-icu : Use the system-wide dev-libs/icu instead of bundled.
        - - system-jpeg : Use the system-wide media-libs/libjpeg-turbo instead of bundled.
        - - system-libevent : Use the system-wide dev-libs/libevent instead of bundled.
        - - system-libvpx : Use the system-wide media-libs/libvpx instead of bundled.
        - - system-sqlite : Use the system-wide dev-db/sqlite installation with secure-delete enabled

    • by Anonymous Coward

      どのみちWindows版は多数のライブラリを同梱する必要がある以上、そういうことが可能な構造を維持しなければならないわけで、あまり楽になる気がしない。

あと、僕は馬鹿なことをするのは嫌いですよ (わざとやるとき以外は)。-- Larry Wall

処理中...