パスワードを忘れた? アカウント作成
この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。

PHP-4.3.7以前にリモート脆弱性発見」記事へのコメント

  • by GPH (8223) on 2004年07月15日 13時48分 (#590001) 日記
    PukiWikiの1.43だかを使っていますが、確かphpのバージョン5だとそのままじゃ動かなかったと書かれていました。
    今回ので4系でもアウトになる・・・なんてこたあまさか無いよなあ・・・。詳しくチェックしてないです。
    • Re:PukiWiki (スコア:3, 参考になる)

      by itiba (10155) on 2004年07月15日 14時05分 (#590018) ホームページ 日記
      続・質問箱/80 [pukiwiki.org]を参照してください。
      PukiWikiはもともと、クラスの使い方がおかしいため(PHP4では、うごいちゃってた)オブジェクト指向周りを書き換えたPHP5では動かないって話です。
      今回の修正点を見る限り、php 4.3.8でちゃんと動くと思います。っていうか家で動いてます。
      PHP5ではどうがんばっても完全に動かすのはだめでした。
      PukiWiki1.5もしくは2.0に期待しましょう。
      親コメント

クラックを法規制強化で止められると思ってる奴は頭がおかしい -- あるアレゲ人

処理中...