パスワードを忘れた? アカウント作成

ohharaさんのトモダチの日記みんなの日記も見てね。 あなたのタレコミがスラドを支えます。さぁ、タレこめ!

11158284 journal
日記

ohharaの日記: Raspberry piでWifi 2

日記 by ohhara

planex kanata 300(GW-300S KATANA)
使用チップはRTL8192EU、メーカーサイトにLinuxドライバソフトが掲載されています。
Raspberry piのRASPBIAN 2014-6-20では自動認識出来ませんでした。
コンパイルにkernel headerソースが必要ですが、raspbianにはバージョンが合うパッケージが無く、
kernelソースからkernelイメージを自作起動させる必要があります。
別バージョンのパッケージをシンボリックリンクして誤魔化しても結果はダメでした。
Raspberry pi でlinuxカーネルのビルドには5,6時間は掛かってしまうので、クロスコンパイル推奨。
容量1GB超えるのでkernelソース転送させるだけでも大変ですが。
やっと準備が出来てドライバをコンパイルさせたけどエラーで失敗。
労力に合わないなと、別の製品に切り替える事にしたorz
情報共有することで何か役に立つかも知れないし、気持ちも切り替えよう。

9146407 journal
日記

ohharaの日記: BeagleBone Black

日記 by ohhara

電力供給不足がストーリーでは話上がってたけど、USB給電は不安なので、うちではAC電源供給してます。
USB HUBもバスパワーよりセルフパワー推奨だね。

最近98円タッパに入れてみました。
https://plus.google.com/u/0/photos/100827122250800238391/albums/5887472692690180321

microSDHCにUbuntu 13.04 (Raring) on ARM入れて自宅サーバーにしてみた。
とりあえずZabbixエージェントで監視もできる。

ただ、LEDの発光がまぶしくて、そのままだと寝られない(笑)

9118050 journal
日記

ohharaの日記: 松本 Linux 勉強会

日記 by ohhara

昨晩6/7に松本にてLinux勉強会の当番担当講師をしてきました。
使用したスライドをGoogleドライブのリンク共有しておきました。

第3回「ネットワーク」
https://docs.google.com/presentation/d/1VuX6wqpuwyLoEEa1I7o5vNgTDBTaoZYGnncMuTzc2p8/edit?usp=sharing

「BeagleBone Black の紹介」
https://docs.google.com/presentation/d/18G_wiq5xkBG1Ya7CMj3XNV-1hwdWAFNNVluDT7_Q4tc/edit?usp=sharing

BeagleBone Black使いだけど、思わずRaspberry Piとムック本の限定セットをポチった(笑)

8966747 journal
Google

ohharaの日記: Devfest Japan Google I/O報告会

日記 by ohhara

地元の信州会場に参加しました。
DevFest Japan 2013 Google I/O 報告会(google.com)

全国7会場を中継で繋いで開催されました。それとUSからも中継がありました。
ハッシュタグの #devfest が急上昇ランキング1位になるなど大盛り上がりでした。
先日開催されたGoogle I/Oの報告会なので既に発表内容は既報の通りですが、
参加者から直接生の雰囲気が聞けて、膨大な内容の中から注目のトピックが聞けました。

・スペシャルゲストのクリスさんがタミヤネタで盛り上がる(笑)
・名古屋会場は何か回ってた(笑)
・クリーチャーとかゆるキャラとかキャラクターがいろいろ徘徊(笑)

色物ネタしか書いてないが、テクニカルなネタはスライドが順次アップされるので、と言うことで。

8369734 journal
日記

ohharaの日記: YAMAHA RTX1200 と NEC IX2015 をNAT-TでVPN接続してみた。

日記 by ohhara

IPsecはespプロトコルでtcpやudpとは別なので、特にNATを越えるのが難しい。
しかし、NAT-T(NATトラバーサル)機能が相互のルータがサポートしていれば、NATを越える事が出来る。
ただしIPsecもNAT-Tも実装がベンダー毎に違いがあり、同一機種同士が無難です。

今回は、ひかり電話ルータのNAT内にIX2015を設置してVPN接続してます。
ひかり電話ルータはesp(IPsec)を通しません。

NAT-Tではespをudpカプセルにしてudp4500ポートで通します。
つまり最初のIKE認証で相互にudp500が接続出来れば、あとはIPsecをNAT-Tで通します。

なお、各WAN側は固定IPアドレスです。
IX2015側から何かパケットを送ればVPN接続されます。

・RTX1200
  LAN側 192.168.1.1/24
ip route 192.168.2.0/24 gateway tunnel 1
tunnel select 1
ipsec tunnel 101
tunnel enable 1
ip route 192.168.2.0/24 gateway tunnel 1
ipsec sa policy 101 1 esp 3des-cbc sha-hmac
ipsec ike always-on 1 on
ipsec ike encryption 1 des-cbc
ipsec ike group 1 modp1024
ipsec ike hash 1 md5
ipsec ike keepalive log 1 on
ipsec ike keepalive use 1 auto heartbeat
ipsec ike local address 1 192.168.1.1
ipsec ike local id 1 192.168.1.0/24
ipsec ike nat-traversal 1 on
ipsec ike payload type 1 3
ipsec ike pfs 1 off
ipsec ike pre-shared-key 1 text password
ipsec ike remote address 1 [相手 IX2015 WAN側IPアドレス]
ipsec ike remote id 1 192.168.2.0/24
ipsec auto refresh 1 on
ip tunnel tcp mss limit auto
ip filter 1 pass * 192.168.1.1 esp * *
ip filter 2 pass * 192.168.1.1 udp * 500
ip filter 3 pass * 192.168.1.1 udp * 4500
nat descriptor masquerade static 1 1 192.168.1.1 esp
nat descriptor masquerade static 1 2 192.168.1.1 udp 500
nat descriptor masquerade static 1 3 192.168.1.1 udp 4500

  ・ひかり電話ルータ
LAN側 192.168.2.1/24
静的NATをIX2015側に設定します。
192.168.2.1 udp 500 -> 192.168.2.2 udp 500
192.168.2.1 udp 4500 -> 192.168.2.2 udp 4500
静的ルーティングもIX2015側に設定します。
192.168.1.0/24 -> 192.168.2.2

  ・IX2015
  LAN側 192.168.2.2/24
ip route default FastEthernet0/0.0
ip route [相手 RTX1200 WAN側IPアドレス]/32 192.168.2.1 FastEthernet0/0.0
ip route 192.168.2.0/24 192.168.2.1 FastEthernet0/0.0
ip route 192.168.1.0/24 Tunnel0.0
ip access-list sec-list permit ip src any dest any
ike initial-contact always
ike proposal ike-pro1 encryption des hash md5 group 1024-bit
ike policy ike-policy1 peer [相手 RTX1200 WAN側IPアドレス] key password ike-pro1
ike keepalive ike-policy1 10 3
ike nat-traversal policy ike-policy1
ipsec autokey-proposal ipsec-pro1 esp-3des esp-sha
ipsec autokey-map ipsec-policy sec-list peer [相手 RTX1200 WAN側IPアドレス] ipsec-pro1
ipsec local-id ipsec-policy 192.168.2.0/24
ipsec remote-id ipsec-policy 192.168.1.0/24
interface FastEthernet0/0.0
ip address 192.168.2.2/24
no shutdown
interface Tunnel0.0
tunnel mode ipsec
ip unnumbered FastEthernet0/0.0
ip tcp adjust-mss auto
ipsec policy tunnel ipsec-policy pre-fragment out
no shutdown

7892867 journal
日記

ohharaの日記: Darkleech Apache Module

日記 by ohhara
7104884 journal
日記

ohharaの日記: Eucalyptus マシンイメージ

日記 by ohhara

Eucalyptus 3.1を使用しているが、CentOS6.3とubuntu 12.04LTSのマシンイメージを入れて無事に動作確認できた。
久しぶりにemis.eucalyptus.com見たらマシンイメージが増えてた。

7068274 journal
日記

ohharaの日記: VPNとファイル共有

日記 by ohhara

主なVPN実装のPPTP、OpenVPN、L2TP/IPSecの各サーバーを構築して、
ファイル共有(SMB or CIFS)を試してみたのだが、やはりレイテンシの影響でパフォーマンスが出ませんでした。
VPNに流すべきプロトコルでは無いですね。
CIFSはLAN内で止めておいて、代わりにWebDAV経由させたら速くなりました。
ここまで来て、わざわざVPN使う必要無いことに気がついて、遠回りしてしまったorz
まぁ各VPN実装の検証が出来たので、勉強だと思っておこう。

typodupeerror

目玉の数さえ十分あれば、どんなバグも深刻ではない -- Eric Raymond

読み込み中...